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В демо-версии управляющие программы можно выдать только для 

двух деталей в карте раскроя. 

6. Назначить маршрут и вывести управляющие 
программы для УЧПУ 

Для вывода карт раскроя в управляющие программы (УП) 

перейдите в режим Маршрут вырезки, автоматически или 

вручную назначьте последовательность обработки контуров на 

карте раскроя и выполните команду Расчет УП в меню Файл. 

Подробное описание этой задачи смотрите в разделе "Назначение 

маршрута вырезки и вывод управляющих программ для УЧПУ". 

Назначение маршрута вырезки и 
вывод управляющих программ для 
УЧПУ 

До вывода карт раскроя в Управляющие программы (УП) 

выполните назначение Маршрута вырезки. После того, как 

маршрут вырезки рассчитан, выполните команду Расчет УП в 

меню Файл. 

Назначение маршрута выполняется в режиме Маршрут вырезки. 

Для возврата к редактированию карт раскроя, перейдите в режим 

План раскроя. 

The demo version generates NC data only for two parts per layout. 

 

6. Defining the cutting path and generating NC data 

To generate NC data from layouts, switch to the Cutting path mode, 

define the cutout processing sequence manually or automatically and 

run the Calculate NC command in the File menu. 

More information on this task is available in the "Defining the cutting 

path and generating control programs for hardware control units" 

section. 

Defining the cutting path and generating 
NC data 

 

To generate NC data from layouts, define the cutting path. Once it has 

been calculated, run the Calculate NC command in the File menu. 

 

Definition of the cutting path is carried out in the Cutting path mode. 

To go back to editing your layout, switch to the Layout mode. 
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 Режим Маршрут вырезки. Кнопка на панели 

инструментов Редактирование 

 Режим План раскроя. Кнопка на панели инструментов 

Редактирование 

Назначение маршрута вырезки (пути инструмента) можно 

выполнить автоматически или вручную. До назначения маршрута 

вырезки проверьте и отредактируйте, если это требуется, 

параметры вырезки (см. раздел Настройка параметров вырезки 

и УП). 

Для автоматического назначения маршрута выполните команду 

Рассчитать маршрут в меню Раскрой. 

 
ВАЖНО: Если маршрут вырезки на карте раскроя 

полностью или частично уже назначен, то выполнение 

автоматического расчета невозможно. Удалите 

существующий маршрут вырезки командой Удалить 

маршрут в меню Правка, чтобы выполнить новый 

автоматический расчет. 

Ручное назначение маршрута вырезки выполняется 

последовательным добавлением контуров на карте раскроя в 

маршрут. 

 

 

 Cutting path mode. A button on the Edit toolbar 

 Layout mode. A button on the Edit toolbar 

You can define the cutting path (to be used by the cutter) manually or 

automatically. Prior to doing this, check and edit the cutting options, if 

necessary (see Customize NC and cutting options). 

 

To define the cutting path automatically, run the Calculate Cutting 

Path command from the Nesting menu. 

 
NOTE: if the cutting path on a specific layout has been completely 

or partially defined, automatic calculation will be impossible. 

Remove the existing path using the Delete path command from 

the Edit menu to use the automatic calculation feature. 

Manual definition of the cutting path is performed by adding individual 

cutouts to the path on a layout. 
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ВАЖНО: Одна деталь может содержать несколько 

контуров: внешний контур и контура внутренних вырезов. 

Как правило, контура внутренних вырезов должны быть 

добавлены в маршрут до внешнего контура детали. Если во 

внутреннем вырезе лежат другие, более мелкие, детали, то 

их контура должны быть добавлены в маршрут перед 

контуром самого выреза. 

Для добавления контура в маршрут выделите контур левым 

щелчком мыши и выполните команду Добавить в маршрут в 

контекстном меню. При этом контур добавляется в конец 

маршрута. 

Если требуется добавить контур после какого-либо уже 

присутствующего в маршруте контура, то выполните команду 

Вставить после в контекстном меню. После выполнения этой 

команды щелкните по контуру, после которого нужно вставить 

выделенный контур. Команда Вставить после позволяет менять 

порядок обработки контуров в уже назначенном маршруте. 

Например, можно удалить контур из маршрута и вставить его 

после какого-либо контура, определив, т.о. новый порядок 

обработки контуров. 

Для удаления контура из маршрута, выделите его и выполните 

команду Удалить из маршрута или нажмите клавишу Del. 

 

 

 
NOTE: a single part can contain several cutouts – for instance, an 

outer cutout and inner cutouts. As a rule, inner cutouts should be 

added to the path before the outer one. If there are other, smaller 

parts in an inner cutout, their cutouts should be added to the path 

first. 

To add a cutout to the cutting path, select it with a click of the left 

mouse button and run the Add to path command from the context 

menu. The cutout will be appended to the end of the path. 

 

If you need to insert a cutout into a sequence of cutouts, use the Insert 

after command from the context menu and click the cutout after which 

you want to insert the current one. The Insert after command enables 

you to change the sequence of cutout processing in the already defined 

path. For instance, you can remove a cutout from the path and insert it 

after another one – that is, to define a new cutout processing sequence. 

 

To remove a cutout from the path, select it and run the Delete from 

path command or just press Del. 
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Для всех добавленных в маршрут контуров автоматически 

рассчитываются элементы маршрута – точки пробивки и входа в 

контур, способ подхода к контуру и выхода из контура, 

направление обхода. Расчет элементов маршрута выполняется в 

соответствии с параметрами вырезки (см. раздел Настройка 

параметров вырезки и УП). Элементы маршрута можно также 

изменить вручную. 

Для изменения элементов вырезки выделите контур, и в 

контекстном меню выберите новое значение элемента. 

Для выбора новой точки входа в контур просто в этой точке 

контура выполните команду Установить вход. Аналогично для 

выбора точки выхода выполняется команда Установить выход. 

Если точка входа в контур и точка выхода не совпадают, то на 

контуре детали остается перемычка, соединяющая деталь с телом 

листа. Если выключен флаг Подход с включенным резом, то 

подход к контуру детали выполняется холостым переходом, иначе 

– режущий инструмент будет включен. 

Для входа в контур можно выбрать следующие способы: по дуге, 

по касательной, по перпендикуляру и под произвольным 

углом. 

Для выхода из контура можно выбрать следующие значения: 

выключение (режущего инструмента) на контуре, по дуге, по 

касательной 

Path elements - such as punch points, lead-ins and lead-outs, machining 

directions – are calculated automatically for all cutouts in the path. 

Calculations of the path elements are carried out according to cutting 

settings (see Customize NC and cutting options). Path elements can 

also be modified manually. 

 

To modify cutting elements, select a cutout and choose a new element 

value in the context menu. 

To define a new lead-in point, simply run the Set lead-in command in 

the necessary point of a cutout. The same applies to the Set lead-out 

command. If the lead-in and lead-out points are not the same, the cutout 

will contain a tab connecting the part to the plate. If the Lead-in with 

On Cutter option is disabled, the cutter will relocate to the cutout in 

the passive mode. Otherwise, the cutter will be enabled. 

 

You can choose the following lead-in options: Arc, Tangentially, 

Normal and Angularly. 

The following lead-out options are available: Off Cutter on Cutout, 

Arc, Tangentially. 
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Для изменения обхода контура выполните команду 

Инвертировать. Направление обхода контура показано 

стрелками, если включен режим Направление обхода в меню 

Вид. 

 
ВАЖНО: Для удобства редактирования маршрута вырезки 

вы можете определить разные цвета всех элементов 

маршрута – холостых и режущих переходов, выделенных 

контуров и пр. Для настройки цвета элементов маршрута 

вырезки, выполните команду Параметры в меню Сервис и 

перейдите в раздел Маршрут – Цвета диалогового окна 

Параметры. 

 

Настройка параметров вырезки и УП 

Параметры маршрута вырезки устанавливаются в окне Свойств 

ГСР на вкладках Маршрут и Правила. Эти свойства можно 

установить для текущей ГСР, выполнив команду Свойства 
ГСР в меню Раскрой, или как свойства ГСР по умолчанию, 

выполнив команду ГСР по умолчанию в меню Файл. 

Вкладка Маршрут (см. рисунок) содержит следующие 

параметры: 

 

To change the machining direction, use the Invert command. The 

machining direction will be shown with arrows if the Machining 

direction mode is enabled in the View menu. 

 
NOTE: for editing convenience, you can define different colors 

to cutting path elements – passive and active relocations, selected 

cutouts, etc. To configure the colors of cutting path elements, use 

the Options command from the Tools menu and switch to the 

Path – Colors section of the Options dialog window. 

 

Customize NC and cutting options 

Cutting path options are defined on the Path and Rules tabs of the 

CNG Properties window. These properties can be applied to the 

current CNG using the CNG Properties command in the Nesting 

menu or made default for all CNG’s with the help of the Default CNG 

command in the File menu. 

The Path tab (see screenshot) contains the following parameters: 
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Ширина реза – зависит от свойств режущего инструмента 

Отстояние пробивки от контура детали – расстояние от центра 

пробивки до эквидистанты, построенной вокруг контура детали на 

расстоянии полуширины реза.  

Положение начальной точки маршрута – начальное положение 

режущего инструмента до начала вырезки. 

Положение конечной точки маршрута – конечное положение 

режущего инструмента после завершения вырезки. 

 

Kerf width – depends on the cutter used 

Distance from Punch Point to Cutout – the distance from the punch 

point to the equidistance curve plotted around the cutout with a margin 

equal to a half of the kerf width 

Start cutting path point – the location of the cutter before the start of 

the cutting process. 

Final cutting path point – the location of the cutter after the cutting 

process is finished. 
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Максимальная длина перехода с резом – это значение 

используется при автоматическом назначении маршрута вырезки. 

Если определенный переход между деталями более указанного 

значения, то выполняется холостой переход с выключенным 

режущим инструментом. 

Длина перемычки – это значение используется при 

автоматической и ручной расстановке перемычек. 

Вкладка Правила (см. рисунок) содержит следующие 

параметры*: 

 

Maximal path with Enable Cutter – this value is used for automatic 

cutting path calculation. If the distance of a specific relocation exceeds 

this value, the cutter will be turned off and relocated in the passive 

mode. 

 

Tab length – the value is used for automatic and manual tab definition. 

The Rules tab (see screenshot) contains the following parameters *: 
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Игнорировать расстояние от края листа для крупных деталей 

– если этот флаг включен, то при формирование карт раскроя 

укладка крупных деталей возможна вплотную к краю листа. Этот 

флаг имеет смысл, если при установленном в параметрах 

расстоянии от края, крупные детали не помещаются в габариты 

листа. 

Длинные и узкие детали всегда укладывать вдоль листа – если 

этот флаг установлен, то при формировании карт раскроя длинные 

узкие детали будут располагаться только вдоль длинной стороны 

листа. Этот флаг имеет смысл, если свойства материала неравно 

распространяются вдоль и поперек листа, например – для 

металлического проката. Использование этого параметра также 

помогает в некоторых случаях избежать выпадение деталей под 

решетку рабочего стола машин тепловой резки. 

Врезка на контуре – этот параметр определяет способ врезки в 

контур детали и содержит значения: По касательной, По 

перпендикуляру, По дуге. 

Врезка на вырезе – этот параметр определяет способ врезки в 

контур внутренних вырезов деталей. 

Обработка конца реза на контуре – этот параметр определяет 

способ завершения резки на контуре и содержит значения: 

Выключение на контуре, Выход по прямой, Выход по дуге. 

 

Ignore plate margins for large parts – if this option is enabled, large 

parts will be nested extremely close to the edge of the plate. The use of 

this option makes sense when large parts don’t fit on the plate with 

edge margins enabled. 

 

Nest longs and narrow parts along a plate – if this option is enabled, 

the program will nest long and narrow parts along the longer side of the 

plate. This option should be used when material properties are unevenly 

distributed along and across the plate – for instance, in metal rolls. This 

option also prevents parts from falling through the grid of thermal 

cutters. 

 

Lead-in on external cutout – this option defined the method of cutting 

into part cutouts and assumes the following values: Tangentially, 

Normal, Arc. 

Lead-in on internal cutout – this option defines the method of cutting 

into internal part cutouts. 

Lead-out on external cutout – this option defines the method of 

finishing the cutting process on part cutouts and assumes the following 

values: Off (cutter) on cutout, Direct, Arc. 
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Обработка конца реза на вырезе – этот параметр определяет 

способ завершения резки на контуре внутреннего вырезка детали. 

* - параметры, приведенные на вкладке Правила имеют 

рекомендательный смысл. Это значит, что преимущественно будет 

применяться установленное значение, но не исключено 

применение других значений. Например, если врезка на контуре 

выбрана По касательной, но взаимное расположение деталей 

таково, что применить этот способ врезки невозможно, то будет 

применена врезка По дуге. 

 

Lead-out on internal cutout – this option defines the method of 

finishing the cutting process on internal part cutouts. 

* - the options listed on the Rules tab are merely recommendations for 

the program. It means that it will use the user-defined settings where 

possible, but other settings may be used as well. For instance, if you 

specified Tangentially as the cut-in method for part cutouts, but the 

parts’ locations do not allow the program to cut this way, the Arc 

method will be used. 


